terminal length 0
sh run
sh ver
sh vtp status
sh vtp password
sh vlan
sh int status
sh int description
sh ip int bri
sh spanning-tree
sh spanning-tree sum
sh spanning-tree root
sh cdp neighbors
sh cdp entry * protocol
sh cdp neighbors detail
sh lldp
2016年11月20日
2016年9月30日
2016年9月17日
Juniper Router BGP路徑選擇
BGP路徑選擇的步驟如下所示:
第一步:各個路徑的 Next-Hop屬性在本地路由表必須是可達的,如果不可達,本地路由器,會丟棄該路徑。
第二步:路由器會選擇具有最佳(高)Local-Preference 屬性值的路徑
第三步:路由器會選擇具有最短 AS Path 長度的路徑
第一步:各個路徑的 Next-Hop屬性在本地路由表必須是可達的,如果不可達,本地路由器,會丟棄該路徑。
第二步:路由器會選擇具有最佳(高)Local-Preference 屬性值的路徑
第三步:路由器會選擇具有最短 AS Path 長度的路徑
2016年8月29日
Cisco BGP 調整Weight 與Local_PREF
透過route-map調整Weight 與Local_PREF的值,來達到控制連出路徑的功能
router bgp 65002
bgp log-neighbor-changes
neighbor 1.1.1.1 remote-as 65051
neighbor 1.1.1.1 ebgp-multihop 2
neighbor 1.1.1.1 soft-reconfiguration inbound
neighbor 1.1.1.1 route-map changelocal in
!
ip prefix-list any-route seq 5 permit 0.0.0.0/0 le 32
!
ip prefix-list google-local-140 seq 5 permit 12.0.0.0/8 le 32
!
ip prefix-list google-local-50 seq 5 permit 8.0.0.0/8 le 32
!
ip prefix-list google-route seq 5 permit 8.0.0.0/8 le 32
!
router bgp 65002
bgp log-neighbor-changes
neighbor 1.1.1.1 remote-as 65051
neighbor 1.1.1.1 ebgp-multihop 2
neighbor 1.1.1.1 soft-reconfiguration inbound
neighbor 1.1.1.1 route-map changelocal in
!
ip prefix-list any-route seq 5 permit 0.0.0.0/0 le 32
!
ip prefix-list google-local-140 seq 5 permit 12.0.0.0/8 le 32
!
ip prefix-list google-local-50 seq 5 permit 8.0.0.0/8 le 32
!
ip prefix-list google-route seq 5 permit 8.0.0.0/8 le 32
!
2016年8月25日
BGP_LAB實作
因為工作的需要,最近又開始了下班回家做LAB的人生Orz.....開始複習起了BGP協定,只不過這次是用Unified Networking Lab的Cisco模擬器來建立BGP LAB,搭配bgpsimple這隻BGP程式來產生上游ISP(AS65000) Internet Transit的BGP route送給LAB裡面的Router,以下為實作架構圖,練習建立eBGP peer和iBGP peer,個人覺得BGP最難的不是設定的方式,而是整個背後運作的原理啊!!!(繼續努力K書中~)
ISP-BGP-PE#show running-config
version 15.2
service timestamps debug datetime localtime
service timestamps log datetime localtime
!
hostname ISP-BGP-PE
!
boot-start-marker
boot-end-marker
!
2016年8月16日
2016年8月14日
2016年8月6日
IPv6 LAB 進階實作
Mikrotik_RouterOS設定
[admin@Mikrotik_RouterOS] > /export
/interface ethernet
set [ find default-name=ether1 ] name=ether1_MGMT speed=1Gbps
set [ find default-name=ether2 ] name=ether2_WAN
set [ find default-name=ether3 ] name=ether3_LAN
/ip address
add address=192.168.88.30/24 interface=ether1_MGMT network=192.168.88.0
add address=192.168.98.254/24 interface=ether3_LAN network=192.168.98.0
/ipv6 address
add address=2001:b034:700:480::254/80 advertise=no interface=ether3_LAN
add address=2001:b034:700:400::1:1/112 advertise=no interface=ether2_WAN
/ipv6 route
add check-gateway=ping distance=1 dst-address=2001:b034:700:480::/64 gateway=2001:b034:700:480::253
/system identity
set name=Mikrotik_RouterOS
2016年8月1日
IPv6 LAB 實作
實作架構圖
ISP_Router#show running-config
Building configuration...
Current configuration : 839 bytes
!
version 15.1
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname ISP_Router
!
ip cef
ipv6 unicast-routing
!
ipv6 cef
!
interface GigabitEthernet0/0
ip address 210.61.79.50 255.255.255.252
duplex auto
speed auto
ipv6 address 2001:B034:700:400::1:2/112
ipv6 enable
!
2016年7月19日
OpenVAS常見問題
常見問題
一、執行yum後會出現”Could not retrieve mirrorlist”
二、掃描時停在1%
It's a bug on the current version. Openvas certs has
expired. There is a workaround to fix it. Please, follow this instructions:
2016年6月25日
網路品質監控Script
最近在查修內部主機間連線Timeout的問題,寫了一個簡單的Script可以做icmp與tcping的每秒監控(依需求修改IP&port),可以用來監控網路品質的狀況,有異常的packet loss都會被記錄下來存成文字檔。
ICMP_Monitor.bat的Script內容如下
@echo off
:loop
echo %date% %time% >> ICMP_Monitor.txt
ping gmail.com -w 1000 -n 10 >> ICMP_Monitor.txt
goto loop
TCP_Ping.bat的Script內容如下
@echo off
:loop
echo %date% %time% >> TCP_Ping.txt
tcping -n 10 -d gmail.com 443>> TCP_Ping.txt
goto loop
收集一天的log文字檔案大小約10MB,關掉視窗就停止監控了
ICMP_Monitor.bat的Script內容如下
@echo off
:loop
echo %date% %time% >> ICMP_Monitor.txt
ping gmail.com -w 1000 -n 10 >> ICMP_Monitor.txt
goto loop
TCP_Ping.bat的Script內容如下
@echo off
:loop
echo %date% %time% >> TCP_Ping.txt
tcping -n 10 -d gmail.com 443>> TCP_Ping.txt
goto loop
收集一天的log文字檔案大小約10MB,關掉視窗就停止監控了
2016年6月10日
透過Splunk 分析惡意C&C伺服器
最近公司有個資安上的需求,需要對於DNS的Log做分析,簡單來說就是有人的電腦可能被植入木馬或是不明原因造成會去連一些惡意的中繼伺服器 (C&C伺服器),雖然已事先在DNS主機上對於這些C&C伺服器清單做了強制的Hosts檔對應到一組不存在的IP,然後再透過Firewall做阻攔,但因為仍無法看到是否為偶發性的上網點到廣告網址或是真的中了木馬才去連線C&C伺服器的List清單,因些有需要將DNS的Log分析,並在有異常時可以自動發出告警信來通知相關資安處理人員。幸好目前的上班公司有買Splunk,那就來做一下大數據分析囉!!!
以下為利用虛擬機器在VM上的LAB實作的步驟
Step 1:先在DNS Sever上將偵錯模式打開,記錄DNS的查詢封包的Log,選勾以下選項可以知道哪些內部電腦查詢了哪些網址,之後會透過Splunk分析這些網址與C&C伺服器清單做大數據比對,不需要勾選到詳細資料的欄位,因為這樣子Log會長的太快,而且不利分析,只需要知道簡單的幾個必要欄位即可
以下為利用虛擬機器在VM上的LAB實作的步驟
Step 1:先在DNS Sever上將偵錯模式打開,記錄DNS的查詢封包的Log,選勾以下選項可以知道哪些內部電腦查詢了哪些網址,之後會透過Splunk分析這些網址與C&C伺服器清單做大數據比對,不需要勾選到詳細資料的欄位,因為這樣子Log會長的太快,而且不利分析,只需要知道簡單的幾個必要欄位即可
2016年5月6日
Cacti Spine poller 安裝
LAB環境 @ CentOS 7
一、安裝前置相關套件
yum install -y gcc mysql-devel net-snmp-devel autoconf automake libtool dos2unix help2man
二、官網download最新版的spine
cd /tmp
wget http://www.cacti.net/downloads/spine/cacti-spine-0.8.8g.tar.gz
tar -xzvf cacti-spine-0.8.8g.tar.gz
三、編譯spine
cd /tmp/cacti-spine-0.8.8g
./bootstrap
./configure
make
make install
一、安裝前置相關套件
yum install -y gcc mysql-devel net-snmp-devel autoconf automake libtool dos2unix help2man
二、官網download最新版的spine
cd /tmp
wget http://www.cacti.net/downloads/spine/cacti-spine-0.8.8g.tar.gz
tar -xzvf cacti-spine-0.8.8g.tar.gz
三、編譯spine
cd /tmp/cacti-spine-0.8.8g
./bootstrap
./configure
make
make install
2016年4月20日
股票配息
中華電信(2412) 股利政策 |
年 度 | 現 金 股 利 | 盈 餘 配 股 | 公 積 配 股 | 股 票 股 利 | 合 計 |
104 | 5.49 | 0.00 | 0.00 | 0.00 | 5.49 |
中鋼(2002) 股利政策 |
年 度 | 現 金 股 利 | 盈 餘 配 股 | 公 積 配 股 | 股 票 股 利 | 合 計 |
104 | 0.50 | 0.00 | 0.00 | 0.00 | 0.50 |
裕民(2606) 股 利 政 策 |
年 度 | 現 金 股 利 | 盈 餘 配 股 | 公 積 配 股 | 股 票 股 利 | 合 計 |
104 | 1.00 | 0.00 | 0.00 | 0.00 | 1.00 |
長興(1717) 股利政策 |
年 度 | 現 金 股 利 | 盈 餘 配 股 | 公 積 配 股 | 股 票 股 利 | 合 計 |
104 | 1.50 | 0.80 | 0.00 | 0.80 | 2.30 |
遠東新(1402) 股利政策 |
年 度 | 現 金 股 利 | 盈 餘 配 股 | 公 積 配 股 | 股 票 股 利 | 合 計 |
104 | 1.00 | 0.00 | 0.00 | 0.00 | 1.00 |
亞泥(1102) 股利政策 |
年 度 | 現 金 股 利 | 盈 餘 配 股 | 公 積 配 股 | 股 票 股 利 | 合 計 |
104 | 1.10 | 0.00 | 0.00 | 0.00 | 1.10 |
2016年2月29日
2016年2月14日
CentOS 7 安裝OpenVAS
官方網站
http://www.openvas.org/
LAB環境:CentOS 7 (minimal install)
一、關掉SELINUX
vi /etc/selinux/config
SELINUX=disabled
# reboot
二、加入相關Repo資源(Atomicorp repo)
wget -q -O - http://www.atomicorp.com/installers/atomic | sh
三、安裝 OpenVAS Redis
yum install redis openvas
四、redis 設定
vi /etc/redis.conf
加入
unixsocket /tmp/redis.sock
unixsocketperm 700
五、 Restart Redis
systemctl enable redis
systemctl restart redis
六、 openvas-setup
http://www.openvas.org/
LAB環境:CentOS 7 (minimal install)
一、關掉SELINUX
vi /etc/selinux/config
SELINUX=disabled
# reboot
二、加入相關Repo資源(Atomicorp repo)
wget -q -O - http://www.atomicorp.com/installers/atomic | sh
三、安裝 OpenVAS Redis
yum install redis openvas
四、redis 設定
vi /etc/redis.conf
加入
unixsocket /tmp/redis.sock
unixsocketperm 700
五、 Restart Redis
systemctl enable redis
systemctl restart redis
六、 openvas-setup
2016年1月5日
MySQL for Cacti 相關指令
建立cacti資料庫
[root@localhost ~]#mysqladmin --user=root create cacti
刪除cacti資料庫
[root@localhost ~]#mysqladmin --user=root drop cacti
顯示cacti資料庫所有table
[root@localhost ~]#mysqlshow -u cactiuser -p cacti
or
mysql> SHOW TABLES FROM cacti;
刪除cacti資料庫特定table
[root@localhost ~]# mysql -u cactiuser -p
Enter password:
mysql> USE cacti;
mysql> drop table syslog,syslog_alert,syslog_incoming,syslog_remove,syslog_reports;
列出所有的資料庫
mysql> SHOW DATABASES;
[root@localhost ~]#mysqladmin --user=root create cacti
刪除cacti資料庫
[root@localhost ~]#mysqladmin --user=root drop cacti
顯示cacti資料庫所有table
[root@localhost ~]#mysqlshow -u cactiuser -p cacti
or
mysql> SHOW TABLES FROM cacti;
刪除cacti資料庫特定table
[root@localhost ~]# mysql -u cactiuser -p
Enter password:
mysql> USE cacti;
mysql> drop table syslog,syslog_alert,syslog_incoming,syslog_remove,syslog_reports;
列出所有的資料庫
mysql> SHOW DATABASES;