2016年8月25日

BGP_LAB實作

因為工作的需要,最近又開始了下班回家做LAB的人生Orz.....開始複習起了BGP協定,只不過這次是用Unified Networking LabCisco模擬器來建立BGP LAB,搭配bgpsimple這隻BGP程式來產生上游ISP(AS65000) Internet Transit的BGP route送給LAB裡面的Router,以下為實作架構圖,練習建立eBGP peeriBGP peer,個人覺得BGP最難的不是設定的方式,而是整個背後運作的原理啊!!!(繼續努力K書中~)
ISP-BGP-PE#show running-config 
version 15.2
service timestamps debug datetime localtime
service timestamps log datetime localtime
!
hostname ISP-BGP-PE
!
boot-start-marker
boot-end-marker
!

!
no aaa new-model
clock timezone TW 8 0
!       
!
no ip domain lookup
ip cef
no ipv6 cef
!
!
multilink bundle-name authenticated
!
!
!
interface Loopback0
 ip address 1.1.1.1 255.255.255.255
!
interface FastEthernet0/0
 ip address 10.254.253.75 255.255.255.0
 duplex full
!
interface FastEthernet1/0
 ip address 10.255.255.100 255.255.255.0
 duplex full
!
interface FastEthernet2/0
 ip address 192.168.90.100 255.255.255.0
 duplex full
!
interface FastEthernet3/0
 no ip address
 shutdown 
 duplex full
!
router bgp 65051
 bgp log-neighbor-changes
 neighbor 2.2.2.2 remote-as 65002
 neighbor 2.2.2.2 ebgp-multihop 2
 neighbor 2.2.2.2 update-source Loopback0
 neighbor 3.3.3.3 remote-as 65051
 neighbor 3.3.3.3 update-source Loopback0
 neighbor 3.3.3.3 next-hop-self
 neighbor 10.254.253.112 remote-as 65000
 neighbor 10.254.253.112 timers 65534 65535
!
ip forward-protocol nd
!
!
no ip http server
no ip http secure-server
ip route 2.2.2.2 255.255.255.255 FastEthernet1/0
ip route 3.3.3.3 255.255.255.255 FastEthernet2/0
!
!
!         
!
control-plane
!
!
line con 0
 exec-timeout 0 0
 logging synchronous
 stopbits 1
line aux 0
 stopbits 1
line vty 0 4
 login
!
ntp master
!
end

Customer-BGP-CE#show running-config 
version 15.2
service timestamps debug datetime localtime
service timestamps log datetime localtime
!
hostname Customer-BGP-CE
!
boot-start-marker
boot-end-marker
!
!
!
no aaa new-model
clock timezone TW 8 0
!
     
!
no ip domain lookup
ip cef
no ipv6 cef
!
!
multilink bundle-name authenticated
!
!
interface Loopback0
 ip address 2.2.2.2 255.255.255.255
!
interface FastEthernet0/0
 no ip address
 shutdown
 duplex full
!
interface FastEthernet1/0
 ip address 10.255.255.200 255.255.255.0
 duplex full
!
router bgp 65002
 bgp log-neighbor-changes
 neighbor 1.1.1.1 remote-as 65051
 neighbor 1.1.1.1 ebgp-multihop 2
 neighbor 1.1.1.1 soft-reconfiguration inbound
!         
ip forward-protocol nd
!
!
no ip http server
no ip http secure-server
ip route 1.1.1.1 255.255.255.255 FastEthernet1/0
!
!
control-plane
!
!
line con 0
 exec-timeout 0 0
 logging synchronous
 stopbits 1
line aux 0
 stopbits 1
line vty 0 4
 login
!
ntp server 10.255.255.100
!
end

iBGP-Router#show running-config 
version 15.2
service timestamps debug datetime localtime
service timestamps log datetime localtime
!
hostname iBGP-Router
!
boot-start-marker
boot-end-marker
!
!
!
no aaa new-model
clock timezone TW 8 0
!        
!
no ip domain lookup
ip cef
no ipv6 cef
!
!
multilink bundle-name authenticated
!
!
interface Loopback0
 ip address 3.3.3.3 255.255.255.255
!
interface FastEthernet0/0
 ip address 192.168.90.200 255.255.255.0
 duplex full
!
interface FastEthernet1/0
 no ip address
 shutdown
 duplex full
!
interface FastEthernet2/0
 no ip address
 shutdown
 duplex full
!
router bgp 65051
 bgp log-neighbor-changes
 neighbor 1.1.1.1 remote-as 65051
 neighbor 1.1.1.1 update-source Loopback0
!
ip forward-protocol nd
!
!
no ip http server
no ip http secure-server
ip route 1.1.1.1 255.255.255.255 FastEthernet0/0
!
!
control-plane
!
!
line con 0
 exec-timeout 0 0
 logging synchronous
 stopbits 1
line aux 0
 stopbits 1
line vty 0 4
 login
!
ntp server 192.168.90.100
!
end






0 回應:

Copyright © 2009 New Life in Taipei All rights reserved. Theme by Laptop Geek. | Bloggerized by FalconHive.