2018年6月12日

股票配息

中華電信(2412) 股利政策
年 度現 金 股 利盈 餘 配 股公 積 配 股股 票 股 利合 計
1064.800.000.000.004.80
中鋼(2002) 股利政策
年 度現 金 股 利盈 餘 配 股公 積 配 股股 票 股 利合 計
1060.880.000.000.000.88
裕民(2606) 股 利 政 策
年 度現 金 股 利盈 餘 配 股公 積 配 股股 票 股 利合 計
1061.200.000.000.001.20
長興(1717) 股利政策
年 度現 金 股 利盈 餘 配 股公 積 配 股股 票 股 利合 計
1060.500.700.000.701.20
遠東新(1402) 股利政策
年 度現 金 股 利盈 餘 配 股公 積 配 股股 票 股 利合 計
1061.200.000.000.001.20
亞泥(1102) 股利政策
年 度現 金 股 利盈 餘 配 股公 積 配 股股 票 股 利合 計
1061.200.000.000.001.20
台灣大(3045) 股利政策
年 度現 金 股 利盈 餘 配 股公 積 配 股股 票 股 利合 計
1065.600.000.000.005.60
合庫金(5880) 股利政策
年 度現 金 股 利盈 餘 配 股公 積 配 股股 票 股 利合 計
1060.750.300.000.301.05
第一金(2892) 股利政策
年 度現 金 股 利盈 餘 配 股公 積 配 股股 票 股 利合 計
1060.900.100.000.101.00
(繼續閱讀...)

2018年5月5日

Linux ICMP 監控Script

每秒發送1個ICMP封包,加上時間標記並記錄下來
[root@Localhost ~]# vi ping_check.sh
#!/bin/bash

DATE=$(date +"%d.%m.%Y %T")
SHORT_DATE=$(date +"%d.%m.%Y")

echo
echo "Pinging host " $@
echo

HOST=$@


ping $HOST | while read PONG
do
        grep -q ttl <<< "$PONG"

        if [ $? -eq 0 ]; then

                echo "`date`: $PONG"
                echo "`date`: $PONG" &>> ping_check_$SHORT_DATE.log

        else

                echo "`date`: ping failed, $HOST host is DOWN!" &>> ping_check_$SHORT_DATE.log
                echo "$PONG" &>> ping_check_$SHORT_DATE.log
        fi
done
(繼續閱讀...)

2018年3月16日

Cisco 2960X NetFlow設定

flow record NETFLOW-RECORD
 match ipv4 tos
 match ipv4 protocol
 match ipv4 source address
 match ipv4 destination address
 match transport source-port
 match transport destination-port
 collect transport tcp flags
 collect interface input
 collect counter bytes long
 collect counter packets long
 collect counter bytes permanent
 collect counter packets permanent
 collect timestamp sys-uptime first
 collect timestamp sys-uptime last
!
flow exporter NETFLOW-EXPORTER
 destination 192.168.88.100
 source Vlan300
 transport udp 9996
!
flow monitor NETFLOW-MONITOR
 exporter NETFLOW-EXPORTER
 cache timeout active 60
 record NETFLOW-RECORD
!
sampler NETFLOW-FLOWSAMPLER
 mode random 1 out-of 500
!
interface GigabitEthernet1/0/1
 ip flow monitor NETFLOW-MONITOR sampler NETFLOW-FLOWSAMPLER input

(繼續閱讀...)

2018年3月8日

Splunk整合Slack發送即時警示訊息

Splunk也可以跟Slack整合即時發送告警訊息,設定方式如下

Step1:先到下方Splunk網頁去捉取Slack Notification Alert應用套件安裝
https://splunkbase.splunk.com/app/2878/

Step2:安裝完成後,在應用套件-->Slack Alerts-->設定  ,將申請好的Slack API Webhook網址貼上去,並存檔,申請API的方式可參考上篇文章連結







Step3:在Splunk頁面-->警示-->設定即時警示動作 ,選擇觸發動作為Slack
照需求選好要發送的頻道,訊息內容的地方,可以個人需求填入,也可以將警示的結果用Splunk定義好的變數參數代入,變數代表的內容可以Splunk網站的這個連結
我使用的變數如下
$server.serverName$:bangbang:$name$:$result._raw$

(繼續閱讀...)

2018年2月28日

Cacti整合Slack發送告警訊息

Slack目前支援使用API或是Webhook的方式來發送訊息到指定的Channel中,Cacti只要稍為調整一下tholdhold的程式後,便可以經由Slack來發送告警訊息並且推播到手機中。下面介紹如何透過Slack Webhook的方式來傳送告警訊息。

一、申請好Slack的帳號,在Slack的網站裡面點選進入APP&Custom Integrations ->Build->Make a Custom Integration 新增 Incoming WebHooks,新增想要送的channels,申請完可以取得Webhook URL

(繼續閱讀...)

2018年2月2日

Cisco NX-OS CLI - Part2

Cisco IOS CLICisco NX-OS CLI
Configuring a Routed Interface
interface gigabitethernet 1/1
ip address 192.168.1.1 255.255.255.0

no shutdown
interface ethernet 1/1
ip address 192.168.1.1/24
no shutdown
Configuring a Switched Interface (VLAN 10)
vlan 10

interface gigabitethernet 1/1

switchport
switchport mode access
switchport access vlan 10

no shutdown
vlan 10

interface ethernet 1/1
switchport
switchport mode access
switchport access vlan 10
no shutdown
Configuring a Switched Virtual Interface (SVI)
Cisco IOS Software does not have the ability to enable or disable SVI interfaces using the feature command.

interface vlan 10

ip address 192.168.1.1 255.255.255.0
no shutdown
feature interface-vlan

interface vlan 10
ip address 192.168.1.1./24
no shutdown
Configuring a Switched Trunk Interface
interface GigabitEthernet 1/1
switchport

switchport trunk encapsulation dot1q
switchport trunk native vlan 2
switchport trunk allowed vlan 10,20
switchport mode trunk

no shutdown
interface ethernet 1/1
switchport mode trunk
switchport trunk allowed vlan 10,20
switchport trunk native vlan 2
no shutdown
Configuring a Routed Trunk Sub-Interface
interface gigabitethernet 1/1
no switchport

no shutdown

interface gigabitethernet1/1.10
encapsulation dot1Q 10
ip address 192.168.1.1 255.255.255.0

no shutdown
interface ethernet 1/1
no switchport
no shutdown

interface ethernet 1/1.10
encapsulation dot1q 10
ip address 192.168.1.1/24
no shutdown

(繼續閱讀...)

Cisco NX-OS CLI - Part1

Cisco IOS CLICisco NX-OS CLI
Default User Prompt
c6500>n7000#
Entering Configuration Mode
c6500# configure terminaln7000# configure terminal
Saving the Running Config to the Startup Config (nvram)
c6500# write memory
or
c6500# copy running-config startup-config
n7000# copy running-config startup-config
Erasing the startup config (nvram)
c6500# write erasen7000# write erase
Installing a License
Cisco IOS Software does not require a license file installation.n7000# install license bootflash:license_file.lic
Interface Naming Convention
interface Ethernet 1/1
interface FastEthernet 1/1
interface GigabitEthernet 1/1
interface TenGigabitEthernet 1/1
interface Ethernet 1/1
Default VRF Configuration (management)
Cisco IOS Software doesn’t enable VRFs by default.vrf context management
Configuring the Software Image Boot Variables
boot system flash sup-bootdisk:s72033-ipservicesk9_wan-mz.122-33.SXH1.binboot kickstart bootflash:/n7000-s1-kickstart.4.0.4.bin sup-1
boot system bootflash:/n7000-s1-dk9.4.0.4.bin sup-1
boot kickstart bootflash:/n7000-s1-kickstart.4.0.4.bin sup-2
boot system bootflash:/n7000-s1-dk9.4.0.4.bin sup-2
Enabling Features
Cisco IOS Software does not have the functionality to enable or disable features.feature ospf
Enabling TELNET (SSHv2 is recommended)
Cisco IOS Software enables TELNET by default.feature telnet
Configuring the Console Timeout
line console 0
exec-timeout 15 0
login
line console
exec-timeout 15
Configuring the VTY Timeout and Session Limit
line vty 0 9
session-limit 10
exec-timeout 15 0
login
line vty
session-limit 10
exec-timeout 15
(繼續閱讀...)

2018年1月1日

Splunk即時告警失效問題

Splunk近期加了不少的即時告警通知的功能,結果在使用上發現會有的部分告警沒辦法正常發送即時通知Email,一開始不以為意,以為是SMTP發信的問題,但後來仔細檢查後,才知道是Splunk為了系統的search效能,所以有做一些預設的限制,而剛好即時告警又是Splunk功能裡很吃效能的一個功能,如果是預設四核心CPU的Splunk主機的話,預設只能同時使用5組的Realtime Alert,這也就是為什麼有時候,有的即時告警正常,有時又異常的原因,要加大可以使用即時告警的數量的話,可修改Splunk安裝目錄下的config檔的參數
C:\Program Files\Splunk\etc\system\default\limits.conf
修改後要記得要重新Restart Splunk services


預設值如下,可用即時告警計算出來,以4 core CPU的話,是只能使用5組
############################################################################
# Concurrency
############################################################################
# This section contains settings for search concurrency limits.
# The total number of concurrent searches is
# base_max_searches + #cpus*max_searches_per_cpu

# The base number of concurrent searches.
base_max_searches = 6

# Max real-time searches = max_rt_search_multiplier x max historical searches.
max_rt_search_multiplier = 1

# The maximum number of concurrent searches per CPU.
max_searches_per_cpu = 1

(繼續閱讀...)

Copyright © 2009 New Life in Taipei All rights reserved. Theme by Laptop Geek. | Bloggerized by FalconHive.